summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2012-08-08 12:21:23 +0200
committerDavid Herrmann <dh.herrmann@googlemail.com>2012-08-08 12:26:35 +0200
commit70a503d00cbcea543f95def953597b74026da2a3 (patch)
treee4082957a59cac7a0dbfafeefe98308e34d48450 /Makefile.am
parent9fe063e2745eef5ff37c2497fafafd4059dd20df (diff)
static: add gl math helpers
These are the same helpers that were previously removed, however, they are now part of the static-kmscon library and can be stripped away by the linker. Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 93a8fd0..99d38fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -258,8 +258,12 @@ libkmscon_static_la_SOURCES = \
external/htable.h \
external/htable.c
+if KMSCON_HAVE_GLES2
nodist_libkmscon_static_la_SOURCES = \
+ src/static_gl.h \
+ src/static_gl_math.c \
src/static_shaders.c
+endif
#
# Binaries