summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPatrick Lam <plam@MIT.EDU>2006-08-04 16:13:00 +0000
committerPatrick Lam <plam@MIT.EDU>2006-08-04 16:13:00 +0000
commit7410e40bd93beb4ab1a577d084112413431cede2 (patch)
tree036eeeccf20ddd740b3c3a18e169951f5f45abdf /configure.in
parent62a4a8459adaf26833e1dad0ee96ea5a4b8c3d54 (diff)
2006-08-04 Keith Packard (keithp@keithp.com) reviewed by: plam
Make cache directories configurable. Simplify and correct some code which deals with per-directory caches.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 16 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index acdc1f1..a3d2c77 100644
--- a/configure.in
+++ b/configure.in
@@ -431,6 +431,22 @@ esac
AC_SUBST(FC_FONTPATH)
+#
+# Set default cache directory path
+#
+AC_ARG_WITH(cache-dir, [ --with-cache-dir=DIR Use DIR to store cache files (default /var/cache/fontconfig)], fc_cachedir="$withval", fc_cachedir=yes)
+
+case $fc_cachedir in
+no|yes)
+ fc_cachedir=`eval echo "${localstatedir}/cache/"${PACKAGE}`
+ ;;
+*)
+ ;;
+esac
+AC_SUBST(fc_cachedir)
+FC_CACHEDIR=${fc_cachedir}
+AC_SUBST(FC_CACHEDIR)
+
FC_FONTDATE=`LC_ALL=C date`
AC_SUBST(FC_FONTDATE)
@@ -516,12 +532,6 @@ fi
AC_SUBST(DOCDIR)
-#
-# Make /var/cache/fontconfig directory available to source code
-#
-
-pkgcachedir='${localstatedir}/cache/'${PACKAGE}
-AC_SUBST(pkgcachedir)
AC_OUTPUT([
Makefile