summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2004-12-05 05:03:52 +0000
committerKeith Packard <keithp@keithp.com>2004-12-05 05:03:52 +0000
commit2d9c79c049d084c82fdda9a71c5a65502ae94cee (patch)
treeca4b7072a4d590541f00da42b7a0ae2891d870d6 /configure.in
parent38e528e77673f0395ab802cd1040947e307f0c6c (diff)
Change default set of fonts to include all of /usr/X11R6/lib/X11/fonts (or
wherever the X fonts are located). Document new <include>directory-name</include> semantics add <include ignore_missing="yes">conf.d</include> Add selectfont to ignore bitmap fonts, add comment for selectfont which accepts bitmap fonts. Allow <include> configuration elements to reference directories. Parse and load all files of the form [0-9]* in sorted order.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 10 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index d28c7bf..540abe4 100644
--- a/configure.in
+++ b/configure.in
@@ -281,19 +281,16 @@ yes)
for dir in /usr/X11R6/lib/X11 /usr/X11/lib/X11 /usr/lib/X11; do
case x"$FC_ADD_FONTS" in
x)
- if test -d "$dir/fonts"; then
- for sub in "$dir"/fonts/*; do
- if ls "$sub" | grep -q -i '\.pf\|\.tt\|\.ot'; then
- case x$FC_ADD_FONTS in
- x)
- FC_ADD_FONTS="$sub"
- ;;
- *)
- FC_ADD_FONTS="$FC_ADD_FONTS,$sub"
- ;;
- esac
- fi
- done
+ sub="$dir/fonts"
+ if test -d "$sub"; then
+ case x$FC_ADD_FONTS in
+ x)
+ FC_ADD_FONTS="$sub"
+ ;;
+ *)
+ FC_ADD_FONTS="$FC_ADD_FONTS,$sub"
+ ;;
+ esac
fi
;;
esac