summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKeith Packard <keithp@neko.keithp.com>2006-08-27 16:25:07 -0700
committerKeith Packard <keithp@neko.keithp.com>2006-08-27 16:25:07 -0700
commit2b629781d74b5a7db1fff873ce5322e59a0f863a (patch)
tree4cf5d140c8570b0bf6691d74235710f41f5662c3 /configure.in
parent199a92241151c391d9becca4fae1cc7e5e32ca80 (diff)
Construct short architecture name from architecture signature.
Map existing architecture signature to short architecture name at build time. This architecture name is (as yet) unused, but will be used to build per-architecture cache files with names made unique by including the architecture name. The auto-detected architecture name can be overridden with the --with-arch=ARCH configure option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a3d2c77..7875831 100644
--- a/configure.in
+++ b/configure.in
@@ -132,6 +132,22 @@ AC_SUBST(EXEEXT_FOR_BUILD)
dnl ==========================================================================
+AC_ARG_WITH(arch, [ --with-arch=ARCH Force architecture to ARCH], arch="$withval", arch=auto)
+
+if test $cross_compiling = yes; then
+ case "$arch" in
+ auto)
+ AC_MSG_ERROR([Cannot autodetect architecture in cross compile environment]
+ [Use --with-arch=ARCH to specify architecture])
+ ;;
+ esac
+fi
+
+ARCHITECTURE=$arch
+AC_SUBST(ARCHITECTURE)
+
+dnl ==========================================================================
+
# Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
@@ -539,6 +555,7 @@ fontconfig/Makefile
fc-lang/Makefile
fc-glyphname/Makefile
fc-case/Makefile
+fc-arch/Makefile
src/Makefile
src/fontconfig.def
conf.d/Makefile