summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2007-02-27 20:27:34 +0000
committerRichard Hughes <richard@hughsie.com>2007-02-27 20:27:34 +0000
commit3a9fbfeab22e073a7c3aa87ec89684cc271c3722 (patch)
tree45ddfb380432a3703f1964003e25773d23aaa1d7 /configure.in
parentc9d60ee8df89bdbdc36ab58c1c5adf86bf5354a0 (diff)
allow use of libparted 1.8.2
Trivial patch, just adds 1.8.2 to the libparted configure list.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8c8ea77d..72859db5 100644
--- a/configure.in
+++ b/configure.in
@@ -164,7 +164,7 @@ if test "x$use_parted" = "xyes" ; then
AC_DEFINE(USE_PARTED,1,[Whether libparted is to be used])
AC_CHECK_LIB(uuid, uuid_generate, [], AC_MSG_ERROR([*** uuid library (libuuid) not found]))
AC_CHECK_LIB(dl, dlopen, [], AC_MSG_ERROR([*** dl library (libdl) not found]))
- AC_MSG_CHECKING(for libparted == 1.7.1, 1.8.0, 1.8.1)
+ AC_MSG_CHECKING(for libparted == 1.7.1, 1.8.0, 1.8.1, 1.8.2)
LDFLAGS=-lparted
AC_TRY_RUN(
#include <stdio.h>
@@ -180,7 +180,8 @@ if test "x$use_parted" = "xyes" ; then
if ((major == 1 && minor == 7 && micro == 1) ||
(major == 1 && minor == 8 && micro == 0) ||
- (major == 1 && minor == 8 && micro == 1))
+ (major == 1 && minor == 8 && micro == 1) ||
+ (major == 1 && minor == 8 && micro == 2))
return 0;
return 1;