summaryrefslogtreecommitdiff
path: root/xts5/Xlib15/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xts5/Xlib15/Makefile.am')
-rw-r--r--xts5/Xlib15/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xts5/Xlib15/Makefile.am b/xts5/Xlib15/Makefile.am
index bfdc4da9..e8105a80 100644
--- a/xts5/Xlib15/Makefile.am
+++ b/xts5/Xlib15/Makefile.am
@@ -4,7 +4,8 @@ AUTOMAKE_OPTIONS = subdir-objects
AM_CFLAGS = $(XTS_LCFLAGS) $(XTS_CFLAGS)
LDADD = $(TCM) $(XTS_LLIBS) $(XTS_LIBS)
-libexec_PROGRAMS = $(tprogs)
+testprogdir = $(libexecdir)/$(subdir)
+nobase_testprog_PROGRAMS = $(tprogs)
BUILT_SOURCES = $(tprogs:$(EXEEXT)=.c)
CLEANFILES = $(BUILT_SOURCES)
@@ -58,7 +59,7 @@ tprogs = \
XWithdrawWindow
# Auxiliary programs run from tests
-libexec_PROGRAMS += \
+nobase_testprog_PROGRAMS += \
XSetWMProperties/Test1 \
XSetWMProperties/Test2
XSetWMProperties_Test1_LDADD = $(TCMCHILD) $(XTS_LLIBS) $(XTS_LIBS)