summaryrefslogtreecommitdiff
path: root/xts5/Xlib12/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-02-17 12:52:46 -0800
committerDan Nicholson <dbn.lists@gmail.com>2010-02-17 12:52:46 -0800
commita282632401e2f17430776294178e14edfd255edb (patch)
tree4dfb935a5cde4aa00fa2347dbb36e532e2c9d7a2 /xts5/Xlib12/Makefile.am
parent868b8c8703842c2b74f370212708f56134afdbcb (diff)
xts5: Use shared library modules to decrease test program size
Linking the xts libraries statically into each test program results in a massive size for the collection of programs. The libraries have been changed to private libtool modules that default to shared, resulting in a much smaller installed size. One consequence of linking to shared objects is that the linker errors on undefined extern variables. The obsolete and unused startup routines in linkstart.c had one of these, so they have been removed from the build. Next is to create the tet library shared.
Diffstat (limited to 'xts5/Xlib12/Makefile.am')
-rw-r--r--xts5/Xlib12/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/xts5/Xlib12/Makefile.am b/xts5/Xlib12/Makefile.am
index 0893d03a..b215452e 100644
--- a/xts5/Xlib12/Makefile.am
+++ b/xts5/Xlib12/Makefile.am
@@ -6,9 +6,9 @@ AM_CFLAGS = -I$(top_srcdir)/include \
-I$(top_srcdir)/xts5/include \
$(XTS_CFLAGS)
LDADD = $(top_builddir)/src/tet3/tcm/libtcmmain.la \
- $(top_builddir)/xts5/src/xim/libximtest.a \
- $(top_builddir)/xts5/src/lib/libxtest.a \
- $(top_builddir)/xts5/fonts/libfont.a \
+ $(top_builddir)/xts5/src/xim/libximtest.la \
+ $(top_builddir)/xts5/src/lib/libxtest.la \
+ $(top_builddir)/xts5/fonts/libfont.la \
$(top_builddir)/src/tet3/apilib/libapi.la \
$(XTS_LIBS)
@@ -49,8 +49,8 @@ tprogs = \
# Auxiliary programs run from tests
nobase_testprog_PROGRAMS += XDisplayName/Test1
XDisplayName_Test1_LDADD = $(top_builddir)/src/tet3/tcm/libtcmchild.la \
- $(top_builddir)/xts5/src/xim/libximtest.a \
- $(top_builddir)/xts5/src/lib/libxtest.a \
- $(top_builddir)/xts5/fonts/libfont.a \
+ $(top_builddir)/xts5/src/xim/libximtest.la \
+ $(top_builddir)/xts5/src/lib/libxtest.la \
+ $(top_builddir)/xts5/fonts/libfont.la \
$(top_builddir)/src/tet3/apilib/libapi.la \
$(XTS_LIBS)