summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-03-06 06:03:00 -0800
committerDan Nicholson <dbn.lists@gmail.com>2012-03-06 06:03:00 -0800
commit85e91b5b9cad1622d5b6c3becbe8175daca76e39 (patch)
tree86a17d796b3fdb6f7da918ed548ba128c6514324 /test/Makefile.am
parent4c2a5182c99fa285743b66a2e8cd8857c978cf78 (diff)
config: Rework Mozilla dependencies so we don't link in libraries
We really only need the headers for xulrunner and nspr and don't want to link anything since the symbols will all resolve at runtime when the plugin is loaded.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 8ffce7a..ac81f41 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,5 @@
-AM_CFLAGS = $(PLUGIN_CFLAGS) $(E_CFLAGS)
-LDADD = $(PLUGIN_LIBS)
+AM_CFLAGS = $(MOZILLA_CFLAGS) $(EVINCE_CFLAGS) $(E_CFLAGS)
+LDADD = $(EVINCE_LIBS)
noinst_PROGRAMS = mime previewer