summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2013-01-11 06:32:31 -0800
committerDan Nicholson <dbn.lists@gmail.com>2013-01-19 16:05:18 -0800
commit70899f8fa6a88c2c7198fc87a39518a7f932ae28 (patch)
treea6de26c24e13ede4b449c5737918808eb3c99188 /test/Makefile.am
parentb98442b260d6568f59ba03e83c0e8711f3371280 (diff)
test: Allow previewer to run with plug in same or separate process
GtkSocket/GtkPlug behave differently when the plug is embedded in the same process rather than running in a separate process. It seems that epiphany does the former while firefox does the latter and that might be causing some of the behavioral differences. When the previewer is run without options, the plug is embedded in the same proceess. When executed with the -f/--fork option, the plug is run from a separate process.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fa84755..94132dd 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,4 @@
-AM_CFLAGS = -I$(top_srcdir)/src $(E_CFLAGS) $(MOZILLA_CFLAGS) \
- -DPLUG_PROCESS=\"$(abs_builddir)/previewer-plug$(EXEEXT)\"
+AM_CFLAGS = -I$(top_srcdir)/src $(E_CFLAGS) $(MOZILLA_CFLAGS)
# use gtk3 if it's available
if ENABLE_GTK3
@@ -10,4 +9,4 @@ AM_CFLAGS += $(EVINCE2_CFLAGS)
LDADD = $(top_builddir)/src/libevbp2-viewer.la
endif
-noinst_PROGRAMS = mime previewer previewer-plug
+noinst_PROGRAMS = mime previewer