summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-05-27 08:33:48 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-05-27 08:33:48 -0700
commit2c458e7c62b59db60304c4b3bf6e2d0a11a85c6d (patch)
tree9b002da940185fd6d2cd5c5a50c3bdd18afd990d /test/Makefile.am
parent89214d98317a6f8a1a4c1efcfd84870f37495a75 (diff)
Add EvbpViewer convenience library to use in tests
Rather than build all the EvbpViewer sources twice, make a convience library for the tests to link to. This does add the unfortunate effect of relinking libevbp-viewer.la and libevbp.la every time there's a change in the source, though.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ee981d3..7b65dd4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,13 +1,4 @@
AM_CFLAGS = -I$(top_srcdir)/src $(MOZILLA_CFLAGS) $(EVINCE_CFLAGS) $(E_CFLAGS)
-LDADD = $(EVINCE_LIBS)
+LDADD = $(top_builddir)/src/libevbp-viewer.la
noinst_PROGRAMS = mime previewer
-
-mime_SOURCES = mime.c $(top_srcdir)/src/evbp-mime.c
-
-previewer_SOURCES = previewer.c \
- $(top_srcdir)/src/evbp-viewer.h $(top_srcdir)/src/evbp-viewer.c \
- $(top_srcdir)/src/ev-page-action.h $(top_srcdir)/src/ev-page-action.c \
- $(top_srcdir)/src/ev-page-action-widget.h \
- $(top_srcdir)/src/ev-page-action-widget.c \
- $(top_srcdir)/src/evbp-mime.h $(top_srcdir)/src/evbp-mime.c