summaryrefslogtreecommitdiff
path: root/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/glapi/gen/Makefile.am')
-rw-r--r--src/mapi/glapi/gen/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/mapi/glapi/gen/Makefile.am b/src/mapi/glapi/gen/Makefile.am
index 311d736abc..25d3e1171e 100644
--- a/src/mapi/glapi/gen/Makefile.am
+++ b/src/mapi/glapi/gen/Makefile.am
@@ -276,8 +276,9 @@ $(MESA_DIR)/main/enums.c: gl_enums.py $(COMMON) templates/enums.c.mako
$(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml \
| $(INDENT) $(INDENT_FLAGS) > $@
-$(MESA_DIR)/main/api_exec.c: gl_genexec.py apiexec.py $(COMMON)
- $(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml > $@
+$(MESA_DIR)/main/api_exec.c: gl_genexec.py $(COMMON) templates/api_exec.c.mako
+ $(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml \
+ | $(INDENT) $(INDENT_FLAGS) > $@
$(MESA_DIR)/main/dispatch.h: gl_table.py $(COMMON) templates/dispatch.h.mako
$(PYTHON_GEN) $< -f $(srcdir)/gl_and_es_API.xml -m remap_table \