summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jose.r.fonseca@gmail.com>2012-04-14 18:13:25 +0100
committerJosé Fonseca <jose.r.fonseca@gmail.com>2012-04-14 18:13:25 +0100
commit4f242f43bf4b3c8f5daadc4496c0e84ae55117b3 (patch)
treee1558f16e701eefe1eeb3794552e430248e94662 /CMakeLists.txt
parentb2f9ad13e08391e2f2c3a83e4225f1ec19eb1c01 (diff)
Move dispatch to its own subdirectory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 2 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d5c99fe..f817701e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -237,17 +237,6 @@ include_directories (
${CMAKE_CURRENT_SOURCE_DIR}/common
)
-add_custom_command (
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/glproc.hpp
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/glproc.py > ${CMAKE_CURRENT_BINARY_DIR}/glproc.hpp
- DEPENDS glproc.py dispatch.py specs/wglapi.py specs/glxapi.py specs/cglapi.py specs/eglapi.py specs/glesapi.py specs/glapi.py specs/gltypes.py specs/stdapi.py
-)
-
-# Wrap glproc.hpp as a target to prevent the command from being executed
-# multiple times simulatenously, when the targets that depend on it are built
-# in parallel.
-add_custom_target (glproc DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/glproc.hpp)
-
if (WIN32)
set (os os_win32.cpp)
set (glws_os glws_wgl.cpp)
@@ -296,14 +285,10 @@ endif ()
##############################################################################
-# API tracers
+# Sub-directories
+add_subdirectory (dispatch)
add_subdirectory (wrappers)
-
-
-##############################################################################
-# API retracers
-
add_subdirectory (retrace)