summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2007-08-01 01:10:50 +0300
committerDaniel Stone <daniel@fooishbar.org>2007-08-01 01:53:31 +0300
commit8658f5d923a69fb55b4cd9e1e84c2d271679f6e2 (patch)
treeff73a6152627f125621afc97cddb73fdfdf28079 /config/Makefile.am
parentaa75b3481724834da2f855d8dd2ff36074bd5706 (diff)
Hotplug: Add HAL support
Add support for HAL-based hotplugging, in which we just get the list of input devices and properties from HAL. Requires an FDI which is not yet in mainline HAL.
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index 527034493..e9811c6c3 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -16,4 +16,8 @@ noinst_LIBRARIES = libconfig.a
libconfig_a_SOURCES += dbus.c
endif
-EXTRA_DIST = xorg-server.conf
+if CONFIG_HAL
+libconfig_a_SOURCES += hal.c
+endif
+
+EXTRA_DIST = xorg-server.conf x11-input.fdi