summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-08-20 18:07:59 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-08-20 18:07:59 +0000
commitbb1d99ee72cc560e95010ea1008d5e796177ae62 (patch)
tree2a6406eb3c5dbaa1fecee664c2ca42396195eb80 /hw/xfree86/dixmods/Makefile.am
parent8a32ed46480d78b69f289c90098f5ed4a830851f (diff)
Build libxkbstubs.la to stub XKB DDX functions (e.g. VT switches), and
build libxorggxkb.la from within the Xorg DDX to replace the previous xf86VT.o, et al, hacks.
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
index 3b1130020..7d745fde1 100644
--- a/hw/xfree86/dixmods/Makefile.am
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -1,4 +1,4 @@
-noinst_LTLIBRARIES = libdixmods.la
+noinst_LTLIBRARIES = libdixmods.la libxorgxkb.la
SUBDIRS = extmod
@@ -97,3 +97,9 @@ libtype1_la_LDFLAGS = -avoid-version
libtype1_la_SOURCES = type1mod.c
libdixmods_la_SOURCES = $(top_srcdir)/mi/miinitext.c
+
+libxorgxkb_la_SOURCES = xkbVT.c xkbPrivate.c xkbKillSrv.c
+
+xkb%.c:
+ echo "#define XF86DDXACTIONS" > $@
+ echo "#include \"$(top_srcdir)/xkb/ddx$*.c\"" >> $@