summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-11-17 09:25:47 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-11-25 10:57:07 +1000
commit8806375ed72a3cd465fe0a49ead079a334accd6b (patch)
tree97a564a9f5d2105143ec14a96c4ab5f13f00fb9e /configure.ac
parenta2adda7ab3defd953cf0f48f5372efb037786a9e (diff)
Move xdmxconfig modules into DMX conditionals (#25102)
xdmxconfig requires additional modules not checked for if Xdmx build is set to auto (the default). This may lead to build errors if the Xdmx modules are installed, but not the extra ones required for xdmxconfig. X.Org Bug 25102 <http://bugs.freedesktop.org/show_bug.cgi?id=25102> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Remi Cardona <remi@gentoo.org> Acked-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4c3b3f8c4..fcd8875af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1881,10 +1881,11 @@ AM_CONDITIONAL(XQUARTZ_SPARKLE, [test "x$XQUARTZ_SPARKLE" != "xno"])
AM_CONDITIONAL(STANDALONE_XPBPROXY, [test "x$STANDALONE_XPBPROXY" = xyes])
dnl DMX DDX
-
PKG_CHECK_MODULES([DMXMODULES],
[xmuu $LIBXEXT x11 xrender xfixes xfont $LIBXI $DMXPROTO xau $XDMCP_MODULES],
- [have_dmx=yes], [have_dmx=no])
+ PKG_CHECK_MODULES([XDMXCONFIG_DEP], [xaw7 xmu xt xpm x11], [have_dmx=yes],
+ [have_dmx=no]),
+ [have_dmx=no])
AC_MSG_CHECKING([whether to build Xdmx DDX])
if test "x$DMX" = xauto; then
DMX="$have_dmx"
@@ -1917,7 +1918,6 @@ dnl USB sources in DMX require <linux/input.h>
dnl Linux sources in DMX require <linux/keyboard.h>
AC_CHECK_HEADER([linux/keyboard.h], DMX_BUILD_LNX="yes",
DMX_BUILD_LNX="no")
- PKG_CHECK_MODULES([XDMXCONFIG_DEP], [xaw7 xmu xt xpm x11])
AC_SUBST(XDMXCONFIG_DEP_CFLAGS)
AC_SUBST(XDMXCONFIG_DEP_LIBS)
PKG_CHECK_MODULES([DMXEXAMPLES_DEP], [$LIBDMX $LIBXEXT x11])