summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-11-17 11:48:35 +1000
committerKeith Packard <keithp@keithp.com>2009-11-16 20:14:34 -0800
commit0ef15ca9d2d9c78c79a2771c550563bc6931b365 (patch)
treee63f817b2852de00902b46f07174cf9484d53c5a /configure.ac
parentdf95be4d3d9a744720e37a16fd89d9569bf6e188 (diff)
Move xdmxconfig modules into DMX conditionals (#25102)
xdmxconfig requires additional modules not checked for if Xdmx build is set to auto (the default). This may lead to build errors if the Xdmx modules are installed, but not the extra ones required for xdmxconfig. X.Org Bug 25102 <http://bugs.freedesktop.org/show_bug.cgi?id=25102> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Tested-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 58d5ead07..417aa4fc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1881,9 +1881,9 @@ AM_CONDITIONAL(XQUARTZ_SPARKLE, [test "x$XQUARTZ_SPARKLE" != "xno"])
AM_CONDITIONAL(STANDALONE_XPBPROXY, [test "x$STANDALONE_XPBPROXY" = xyes])
dnl DMX DDX
-
+XDMXCONFIG_MODULES="xaw7 xmu xt xpm x11"
PKG_CHECK_MODULES([DMXMODULES],
- [xmuu $LIBXEXT x11 xrender xfixes xfont $LIBXI $DMXPROTO xau $XDMCP_MODULES],
+ [xmuu $LIBXEXT x11 xrender xfixes xfont $LIBXI $DMXPROTO xau $XDMCP_MODULES $XDMXCONFIG_MODULES],
[have_dmx=yes], [have_dmx=no])
AC_MSG_CHECKING([whether to build Xdmx DDX])
if test "x$DMX" = xauto; then
@@ -1917,7 +1917,7 @@ dnl USB sources in DMX require <linux/input.h>
dnl Linux sources in DMX require <linux/keyboard.h>
AC_CHECK_HEADER([linux/keyboard.h], DMX_BUILD_LNX="yes",
DMX_BUILD_LNX="no")
- PKG_CHECK_MODULES([XDMXCONFIG_DEP], [xaw7 xmu xt xpm x11])
+ PKG_CHECK_MODULES([XDMXCONFIG_DEP], [$XDMXCONFIG_MODULES])
AC_SUBST(XDMXCONFIG_DEP_CFLAGS)
AC_SUBST(XDMXCONFIG_DEP_LIBS)
PKG_CHECK_MODULES([DMXEXAMPLES_DEP], [$LIBDMX $LIBXEXT x11])