summaryrefslogtreecommitdiff
path: root/GL/mesa/X/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'GL/mesa/X/Makefile.am')
-rw-r--r--GL/mesa/X/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/GL/mesa/X/Makefile.am b/GL/mesa/X/Makefile.am
index 80fa91530..56b62e765 100644
--- a/GL/mesa/X/Makefile.am
+++ b/GL/mesa/X/Makefile.am
@@ -12,10 +12,11 @@ INCLUDES = -I@MESA_SOURCE@/include \
-I../tnl \
-I.. \
-I$(top_srcdir)/GL/glx \
- -I$(top_srcdir)/GL/include
+ -I$(top_srcdir)/GL/include \
+ -I$(top_srcdir)/hw/xfree86/os-support
# terribly gross hack. i need a shower now.
-AM_CFLAGS = $(DIX_CFLAGS) -DXFree86Server -include dix-config.h
+AM_CFLAGS = $(DIX_CFLAGS) -DXFree86Server @MODULE_DEFINES@ @LOADER_DEFINES@
libX_la_SOURCES = xf86glx.c \
xf86glx_util.c \