summaryrefslogtreecommitdiff
path: root/mi/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2010-06-22 12:11:20 -0700
committerKeith Packard <keithp@keithp.com>2010-06-22 12:11:20 -0700
commite2918b67395a48397bf7db545584cc2d4f4e7ccf (patch)
tree6debd0d80c7d9dbf5a439c374f179547d80d581f /mi/Makefile.am
parent7673451ade46ebacfdfc02a5190149210198fdd8 (diff)
Revert "mi: Remove unused overlay support"
This reverts commit 9120e58556014e514eef9dfe43cdea4b74dc66ae. Whoops, please revert this patch -- overlay is in use in nvidia drivers, and it's too late in release cycle to remove it. I feel really sorry that I kept this patch in my tree. I will submit another one, removing only XAA overlay hooks which are not used at all.
Diffstat (limited to 'mi/Makefile.am')
-rw-r--r--mi/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/mi/Makefile.am b/mi/Makefile.am
index 831922634..f6dabda67 100644
--- a/mi/Makefile.am
+++ b/mi/Makefile.am
@@ -3,7 +3,7 @@ noinst_LTLIBRARIES = libmi.la
if XORG
sdk_HEADERS = micmap.h miline.h mipointer.h mi.h mibstore.h \
migc.h mipointrst.h mizerarc.h micoord.h mifillarc.h \
- mispans.h miwideline.h mistruct.h mifpoly.h
+ mispans.h miwideline.h mistruct.h mifpoly.h mioverlay.h
endif
AM_CFLAGS = $(DIX_CFLAGS)
@@ -33,6 +33,8 @@ libmi_la_SOURCES = \
migc.h \
miglblt.c \
miline.h \
+ mioverlay.c \
+ mioverlay.h \
mipointer.c \
mipointer.h \
mipointrst.h \