summaryrefslogtreecommitdiff
path: root/GL/glx/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-01-15 19:43:16 -0800
committerDan Nicholson <dbn.lists@gmail.com>2008-02-17 17:37:33 -0800
commit45d00433e7bfbab476dd02ec92a9fbee40af5dad (patch)
treec1782292ef660d636d61e05141860441a7f69186 /GL/glx/Makefile.am
parentfbd776894658e7afb2c55dc8582b2a3efab78a3c (diff)
glx: Use glapi sources from the mesa tree
With recent mesa HEAD, the glapi sources used only in the xserver glx module are carried in the mesa tree. Previously, these were generated separately and committed to the xserver tree. The build is changed to symlink these files like the other mesa sources. This reduces the chance for mismatches between mesa's glX API and the xserver's glX API.
Diffstat (limited to 'GL/glx/Makefile.am')
-rw-r--r--GL/glx/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/GL/glx/Makefile.am b/GL/glx/Makefile.am
index e37e499c5..377d76019 100644
--- a/GL/glx/Makefile.am
+++ b/GL/glx/Makefile.am
@@ -33,7 +33,15 @@ nodist_libglx_la_SOURCES = indirect_size.h \
glapi.c \
glcontextmodes.c \
glcontextmode.h \
- glthread.c
+ glthread.c \
+ indirect_dispatch.c \
+ indirect_dispatch.h \
+ indirect_dispatch_swap.c \
+ indirect_reqsize.c \
+ indirect_reqsize.h \
+ indirect_size_get.c \
+ indirect_size_get.h \
+ indirect_table.c
libglxdri_la_SOURCES = \
glxdri.c \
@@ -56,15 +64,7 @@ libglx_la_SOURCES = \
glxserver.h \
glxutil.c \
glxutil.h \
- indirect_dispatch.c \
- indirect_dispatch.h \
- indirect_dispatch_swap.c \
indirect_program.c \
- indirect_reqsize.c \
- indirect_reqsize.h \
- indirect_size_get.c \
- indirect_size_get.h \
- indirect_table.c \
indirect_table.h \
indirect_texture_compression.c \
indirect_util.c \