summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJonathan Blandford <jrb@redhat.com>2005-08-23 18:20:45 +0000
committerJonathan Blandford <jrb@redhat.com>2005-08-23 18:20:45 +0000
commitda3aac379f07ffedd6078707ec9923800fc0c0a5 (patch)
treed7d48b77339cb6e9411d1070004d787e3263d27e /test/Makefile.am
parent1aad886c6c19a964a3fc9e18f31acc8e115478e0 (diff)
Tue Aug 23 13:38:01 2005 Jonathan Blandford <jrb@redhat.com>
* configure.ac: * poppler/Gfx.cc: * poppler/Gfx.h: * poppler/GlobalParams.cc: * poppler/GlobalParams.h: * poppler/Makefile.am: * poppler/OutputDev.cc: * poppler/OutputDev.h: * poppler/ProfileData.cc: * poppler/ProfileData.h: * test/Makefile.am: * test/pdf-inspector.cc: * test/pdf-inspector.glade: * test/pdf-operators.c: Initial cut at a pdf inspector. This should help us look at PDF files.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c9f41b94..57b3aaf7 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -15,6 +15,9 @@ if BUILD_CAIRO_OUTPUT
gtk_cairo_test = \
gtk-cairo-test
+pdf_inspector = \
+ pdf_inspector
+
cairo_includes = \
$(CAIRO_CFLAGS)
@@ -30,7 +33,7 @@ INCLUDES = \
$(GTK_TEST_CFLAGS) \
-DDATADIR=\""$(datadir)"\"
-noinst_PROGRAMS = $(gtk_splash_test) $(gtk_cairo_test)
+noinst_PROGRAMS = $(gtk_splash_test) $(gtk_cairo_test) $(pdf_inspector)
gtk_splash_test_SOURCES = \
gtk-splash-test.cc
@@ -46,3 +49,11 @@ gtk_cairo_test_LDADD = \
$(top_builddir)/poppler/libpoppler.la \
$(CAIRO_LIBS) \
$(GTK_TEST_LIBS)
+
+pdf_inspector_SOURCES = \
+ pdf-inspector.cc
+
+pdf_inspector_LDADD = \
+ $(top_builddir)/poppler/libpoppler.la \
+ $(CAIRO_LIBS) \
+ $(GTK_TEST_LIBS)