summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2011-08-25 20:43:51 +0200
committerChristian Kellner <gicmo@gnome.org>2011-08-25 21:19:57 +0200
commitc5ecea345cda45f670d89e0f2627afa199fadb30 (patch)
tree8a664b9a99166ce19a74f4ff9558dff4f0f350de /daemon/Makefile.am
parent5c1242031634859004ce330581342c273a251d20 (diff)
afp: make the afp backends optional
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 67e1d546..6ca840b7 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -40,10 +40,10 @@ service_DATA = gvfs-daemon.service
%.mount: %.mount.in ../config.log
$(AM_V_GEN) $(SED) -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
-libexec_PROGRAMS=gvfsd gvfsd-sftp gvfsd-trash gvfsd-computer gvfsd-burn gvfsd-localtest gvfsd-ftp gvfsd-network gvfsd-afp-browse gvfsd-afp
+libexec_PROGRAMS=gvfsd gvfsd-sftp gvfsd-trash gvfsd-computer gvfsd-burn gvfsd-localtest gvfsd-ftp gvfsd-network
-mount_in_files = sftp.mount.in trash.mount.in computer.mount.in burn.mount.in localtest.mount.in network.mount.in afp-browse.mount.in afp.mount.in
-mount_DATA = sftp.mount trash.mount computer.mount burn.mount localtest.mount network.mount afp-browse.mount afp.mount
+mount_in_files = sftp.mount.in trash.mount.in computer.mount.in burn.mount.in localtest.mount.in network.mount.in
+mount_DATA = sftp.mount trash.mount computer.mount burn.mount localtest.mount network.mount
mount_in_files += http.mount.in dav.mount.in dav+sd.mount.in ftp.mount.in
if HAVE_HTTP
@@ -108,6 +108,12 @@ mount_DATA += afc.mount
libexec_PROGRAMS += gvfsd-afc
endif
+mount_in_files += afp-browse.mount.in afp.mount.in
+if USE_AFP
+mount_DATA += afp-browse.mount afp.mount
+libexec_PROGRAMS += gvfsd-afp-browse gvfsd-afp
+endif
+
EXTRA_DIST = \
gvfs-daemon.service.in \
$(mount_in_files) \