summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 6a43ee437..0f4f86518 100644
--- a/configure.in
+++ b/configure.in
@@ -362,12 +362,16 @@ case $HAVE_GST_VER in
;;
esac
-AC_SUBST(MIXER_CFLAGS)
-AC_SUBST(MIXER_LIBS)
-
AM_CONDITIONAL(APPLET_MIXER, test "x$HAVE_GST" = "xyes")
AM_CONDITIONAL(HAVE_GST10, test "x$HAVE_GST_VER" = "x0.10")
-AC_DEFINE(HAVE_GST10, test "x$HAVE_GST_VER" = "x0.10", [Using Gstreamer 0.10])
+if test "x$HAVE_GST_VER" = "x0.10" ; then
+ AC_DEFINE(HAVE_GST10, 1, [Using Gstreamer 0.10])
+ # these don't seem to come from any pkg-config file
+ MIXER_LIBS="$MIXER_LIBS -lgstinterfaces-0.10 -lgstaudio-0.10"
+fi
+
+AC_SUBST(MIXER_CFLAGS)
+AC_SUBST(MIXER_LIBS)
dnl ***************************************
dnl ** Check for libnotify **