summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-10-12 17:24:20 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-10-12 18:00:16 -0400
commitf0152daad719209d6984217e43dc79eb47d102c9 (patch)
tree17a7154e286d6fb8e193dd3701c39b200800a17f /clients/Makefile.am
parent49291497d3cb696bb9b17033c38859eaf1cc1be8 (diff)
Use automake
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
new file mode 100644
index 0000000..9277e77
--- /dev/null
+++ b/clients/Makefile.am
@@ -0,0 +1,36 @@
+noinst_PROGRAMS = gears flower screenshot terminal image view dnd
+noinst_LTLIBRARIES = libtoytoolkit.la
+
+INCLUDES = -I$(top_srcdir)/wayland $(CLIENT_CFLAGS) $(POPPLER_CFLAGS)
+
+LDADD = $(top_builddir)/wayland/libwayland-client.la \
+ libtoytoolkit.la $(CLIENT_LIBS) -lrt -lm
+
+AM_CPPFLAGS = -DDATADIR='"$(datadir)"'
+
+libtoytoolkit_la_SOURCES = \
+ window.c \
+ window.h \
+ wayland-glib.c \
+ wayland-glib.h \
+ cairo-util.c \
+ cairo-util.h
+
+flower_SOURCES = flower.c
+gears_SOURCES = gears.c
+screenshot_SOURCES = screenshot.c screenshooter-protocol.c
+terminal_SOURCES = terminal.c
+image_SOURCES = image.c
+view_SOURCES = view.c
+dnd_SOURCES = dnd.c
+
+BUILT_SOURCES = \
+ screenshooter-client-protocol.h \
+ screenshooter-protocol.c
+
+CLEANFILES = $(BUILT_SOURCES)
+
+include $(top_srcdir)/wayland/scanner.mk
+
+terminal_LDADD = $(LDADD) -lutil
+view_LDADD = $(LDADD) $(POPPLER_LIBS)