summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@intel.com>2011-07-21 16:35:40 +0300
committerKristian Høgsberg <krh@bitplanet.net>2011-07-21 08:42:58 -0700
commit93165e3e236c058bb6cf1b86a96b16fcd26b7143 (patch)
tree18874281c10c33bc603247b5421df4346e99de02 /clients/Makefile.am
parente81fe8346c1c474936014ec24c262370c16eb962 (diff)
configure: set up simple clients independently from the others
Namely, simple-client and simple-shm. Signed-off-by: Tiago Vignatti <tiago.vignatti@intel.com>
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am27
1 files changed, 16 insertions, 11 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
index fa99be6..f3999bf 100644
--- a/clients/Makefile.am
+++ b/clients/Makefile.am
@@ -1,15 +1,25 @@
-noinst_PROGRAMS = \
- gears \
+noinst_PROGRAMS = $(clients_programs) \
+ $(poppler_programs) \
+ $(simple_clients_programs)
+
+if BUILD_SIMPLE_CLIENTS
+simple_clients_programs = simple-client simple-shm
+simple_client_SOURCES = simple-client.c
+simple_client_LDADD = $(SIMPLE_CLIENT_LIBS) -lm
+
+simple_shm_SOURCES = simple-shm.c
+simple_shm_LDADD = $(SIMPLE_CLIENT_LIBS)
+endif
+
+if BUILD_CLIENTS
+clients_programs = gears \
flower \
screenshot \
terminal \
image \
- $(poppler_programs) \
dnd \
smoke \
resizor \
- simple-client \
- simple-shm \
eventdemo
noinst_LIBRARIES = libtoytoolkit.a
@@ -55,12 +65,6 @@ smoke_LDADD = $(toolkit_libs)
resizor_SOURCES = resizor.c
resizor_LDADD = $(toolkit_libs)
-simple_client_SOURCES = simple-client.c
-simple_client_LDADD = $(SIMPLE_CLIENT_LIBS) -lm
-
-simple_shm_SOURCES = simple-shm.c
-simple_shm_LDADD = $(SIMPLE_CLIENT_LIBS)
-
eventdemo_SOURCES = eventdemo.c
eventdemo_LDADD = $(toolkit_libs)
@@ -69,6 +73,7 @@ BUILT_SOURCES = \
screenshooter-protocol.c
CLEANFILES = $(BUILT_SOURCES)
+endif
@wayland_scanner_rules@