summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2011-11-17 11:33:06 +0200
committerPekka Paalanen <ppaalanen@gmail.com>2011-11-18 14:46:26 +0200
commit11f53f56dbbc9d204629b6cdfd970eb4e9abf422 (patch)
tree190b8ac9e74b5b24b2ccb5ac655521971bd8378c /clients/Makefile.am
parent8260f460d7493532bfdf15199260c64fc0c8b2c8 (diff)
clients: add wscreensaver
Implement all the required support code for running glmatrix.c. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
index bae9f3f..1f7125f 100644
--- a/clients/Makefile.am
+++ b/clients/Makefile.am
@@ -23,6 +23,7 @@ clients_programs = \
dnd \
smoke \
resizor \
+ wscreensaver \
eventdemo
desktop_shell = wayland-desktop-shell
@@ -69,6 +70,9 @@ smoke_LDADD = $(toolkit_libs)
resizor_SOURCES = resizor.c
resizor_LDADD = $(toolkit_libs)
+wscreensaver_SOURCES = wscreensaver.c wscreensaver-glue.c glmatrix.c
+wscreensaver_LDADD = $(toolkit_libs) -lGLU
+
eventdemo_SOURCES = eventdemo.c
eventdemo_LDADD = $(toolkit_libs)