summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-09-06 18:02:34 -0400
committerKristian Høgsberg <krh@bitplanet.net>2011-09-06 18:02:34 -0400
commit0c29eb292e17ee88b0380a7bbb8702616b0a6b5f (patch)
treea2957bd8eb41d6498c310c177a7fa78dfbebdfad /clients/Makefile.am
parent900b226ac12d133290338eb9c17dec9e0340c9a2 (diff)
clients: Add a simple desktop-shell app
This just provides the background surface and the top panel.
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
index 8233e38..ee56169 100644
--- a/clients/Makefile.am
+++ b/clients/Makefile.am
@@ -12,7 +12,8 @@ simple_shm_LDADD = $(SIMPLE_CLIENT_LIBS)
endif
if BUILD_CLIENTS
-clients_programs = gears \
+clients_programs = \
+ gears \
flower \
screenshot \
terminal \
@@ -20,7 +21,8 @@ clients_programs = gears \
dnd \
smoke \
resizor \
- eventdemo
+ eventdemo \
+ desktop-shell
noinst_LIBRARIES = libtoytoolkit.a
@@ -68,9 +70,17 @@ resizor_LDADD = $(toolkit_libs)
eventdemo_SOURCES = eventdemo.c
eventdemo_LDADD = $(toolkit_libs)
+desktop_shell_SOURCES = \
+ desktop-shell.c \
+ desktop-shell-client-protocol.h \
+ desktop-shell-protocol.c
+desktop_shell_LDADD = $(toolkit_libs)
+
BUILT_SOURCES = \
screenshooter-client-protocol.h \
- screenshooter-protocol.c
+ screenshooter-protocol.c \
+ desktop-shell-client-protocol.h \
+ desktop-shell-protocol.c
CLEANFILES = $(BUILT_SOURCES)
endif