summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-04-19 12:12:13 +0300
committerPekka Paalanen <ppaalanen@gmail.com>2012-04-19 12:12:13 +0300
commit84464a3e9b5f16ab805ee3166901dd264a3898a7 (patch)
tree03d84caa0f9dff23b3f63e3be7f3b6d6303ab09d /tests/Makefile.am
parentb7c7963f160f951fbc8ef10923a5264fec28cbd7 (diff)
tests: put common test source files in a variable
Makes all test targets have the same common make dependencies. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cc4b9cc..e14f757 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -9,12 +9,14 @@ check_PROGRAMS = \
event-loop-test \
client-test
-map_test_SOURCES = map-test.c test-runner.c test-runner.h
-array_test_SOURCES = array-test.c test-runner.c
-list_test_SOURCES = list-test.c test-runner.c
-connection_test_SOURCES = connection-test.c test-runner.c
-event_loop_test_SOURCES = event-loop-test.c test-runner.c
-client_test_SOURCES = client-test.c test-runner.c
+test_runner_src = test-runner.c test-runner.h
+
+map_test_SOURCES = map-test.c $(test_runner_src)
+array_test_SOURCES = array-test.c $(test_runner_src)
+list_test_SOURCES = list-test.c $(test_runner_src)
+connection_test_SOURCES = connection-test.c $(test_runner_src)
+event_loop_test_SOURCES = event-loop-test.c $(test_runner_src)
+client_test_SOURCES = client-test.c $(test_runner_src)
AM_CFLAGS = $(GCC_CFLAGS)
LDADD = $(top_builddir)/src/libwayland-util.la \