summaryrefslogtreecommitdiff
path: root/test/test-automation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/test-automation/Makefile.am')
-rw-r--r--test/test-automation/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/test-automation/Makefile.am b/test/test-automation/Makefile.am
new file mode 100644
index 00000000..3b653e62
--- /dev/null
+++ b/test/test-automation/Makefile.am
@@ -0,0 +1,16 @@
+ACLOCAL_AMFLAGS = -I acinclude -I build-scripts
+
+SUBDIRS = tests
+
+bin_PROGRAMS = runner
+runner_SOURCES = runner.c
+runner_CLAGS = -W -Wall -Wextra -g `sdl-config --cflags` -DSDL_NO_COMPAT
+runner_LDFLAGS = `sdl-config --libs`
+
+install: install-tests
+ ;
+
+install-tests:
+ cp -f tests/.libs/*.dylib tests/
+
+