summaryrefslogtreecommitdiff
path: root/libs/gst/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2012-01-17 23:57:44 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2012-01-18 01:22:52 +0000
commitf7f19d9589110feaa94efbf5964b67475d79b227 (patch)
tree1528b76b099461df7a4ad906ebe40d3519fb8869 /libs/gst/Makefile.am
parent4d27e79429d2cffa6b04cbb83fe65def0454426c (diff)
configure: remove --disable-net option and always build libgstnet
It should work everywhere now, and -base and -good depend on the GstNetMeta API.
Diffstat (limited to 'libs/gst/Makefile.am')
-rw-r--r--libs/gst/Makefile.am18
1 files changed, 2 insertions, 16 deletions
diff --git a/libs/gst/Makefile.am b/libs/gst/Makefile.am
index f638e616f..d02c4c774 100644
--- a/libs/gst/Makefile.am
+++ b/libs/gst/Makefile.am
@@ -4,29 +4,15 @@ else
SUBDIRS_CHECK =
endif
-if GST_DISABLE_NET
-SUBDIRS_NET =
-else
-if HAVE_SYS_SOCKET_H
-SUBDIRS_NET = net
-else
-if HAVE_WINSOCK2_H
-SUBDIRS_NET = net
-else
-SUBDIRS_NET =
-endif
-endif
-endif
-
if GST_DISABLE_REGISTRY
SUBDIRS_HELPERS =
else
SUBDIRS_HELPERS = helpers
endif
-SUBDIRS_ALWAYS = base controller
+SUBDIRS_ALWAYS = base controller net
-SUBDIRS = $(SUBDIRS_ALWAYS) $(SUBDIRS_CHECK) $(SUBDIRS_NET) $(SUBDIRS_HELPERS)
+SUBDIRS = $(SUBDIRS_ALWAYS) $(SUBDIRS_CHECK) $(SUBDIRS_HELPERS)
DIST_SUBDIRS = $(SUBDIRS_ALWAYS) check net helpers
Android.mk: Makefile.am