summaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
authorStefan Sauer <ensonic@users.sf.net>2016-01-12 14:59:04 +0100
committerStefan Sauer <ensonic@users.sf.net>2016-01-15 21:54:01 +0100
commit10b78d872b5a0050c8a4572267879b0adbb578f8 (patch)
treed49e466ba2cab09019fafbcffec6bed870a76f1b /gst/Makefile.am
parent7b49459f1ae42a08afff326567f028d1e583b960 (diff)
tracerrecord: add a log record class
We use this class to register tracer log entry metadata and build a log template. With the log template we can serialize log data very efficiently. This also simplifies the logging code, since that is now a simple varargs function that is not exposing the implementation details. Add docs for the new class and basic tests. Remove the previous log handler. Fixes #760267
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index fa1ea7b5b..224544c9b 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -117,6 +117,7 @@ libgstreamer_@GST_API_VERSION@_la_SOURCES = \
$(GST_TRACE_SRC) \
gsttracer.c \
gsttracerfactory.c \
+ gsttracerrecord.c \
gsttracerutils.c \
gsttypefind.c \
gsttypefindfactory.c \
@@ -223,6 +224,7 @@ gst_headers = \
gsttocsetter.h \
gsttracer.h \
gsttracerfactory.h \
+ gsttracerrecord.h \
gsttypefind.h \
gsttypefindfactory.h \
gsturi.h \