summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am42
1 files changed, 18 insertions, 24 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index da04cda..c0d9007 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,27 +1,21 @@
-EXTRA_DIST = HEAD.in docutils.conf gst-python.css
+XMLFILES = gst-python.xml
+XSLFILES = common.xsl html.xsl
+CSSFILES = gst-python.css
-DOCS = \
- $(srcdir)/HEAD \
- $(top_srcdir)/NEWS \
- $(top_srcdir)/README \
- $(top_srcdir)/TODO \
- $(top_srcdir)/AUTHORS
+DOCS = gst-python.txt gst-python.html
-gst-python.html: docutils.conf ${DOCS}
- @if [ ! $$DOCUTILSHOME ]; then \
- echo "ERROR: Please set \$$DOCUTILSHOME"; \
- exit 1; \
- fi
- @if [ ! -r $$DOCUTILSHOME/tools/html.py ]; then \
- echo "\$$DOCUTILSHOME/tools/html.py not found"; \
- exit 1; \
- fi
- rm -f gst-python.txt
- for doc in ${DOCS}; do \
- cat $$doc >> gst-python.txt; \
- printf "\n" >> gst-python.txt; \
- done
- PYTHONPATH=$$PYTHONPATH:$$DOCUTILSHOME $$DOCUTILSHOME/tools/html.py gst-python.txt gst-python.html
- lynx -dump -force_html gst-python.html > gst-python.out
+all: $(DOCS)
-CLEANFILES = gst-python.txt gst-python.html
+gst-python.txt: gst-python.xml
+ xmlto txt $<
+# cp gst-python.txt $(top_builddir)/../README
+
+gst-python.html: gst-python.xml common.xsl html.xsl
+ xmlto -m common.xsl -m html.xsl xhtml-nochunks $<
+
+gst-python.pdf: gst-python.xml common.xsl pdf.xsl
+ xmlto -m common.xsl -m pdf.xsl pdf $<
+
+CLEANFILES = $(DOCS)
+
+EXTRA_DIST = $(XMLFILES) $(XSLFILES) $(CSSFILES)