summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-02-26 15:46:58 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-02-26 15:46:58 +0100
commitdaab7d1c40b12b2449270851c6e54ba716b9ecda (patch)
tree5fee03897cb56455ffd51b1f9b02ad2c38126b04 /configure.ac
parent3921fd7493fb463ee786817f21a0c07674e7ff5d (diff)
configure: Use automake 1.11 silent rules instead of shave if available
This makes sure that we use something that is still maintained and also brings back libtool 1.5 support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a8a59a7..474192f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,11 @@ AM_CONFIG_HEADER([config.h])
dnl AM_MAINTAINER_MODE only provides the option to configure to enable it
AM_MAINTAINER_MODE
+dnl use pretty build output with automake >= 1.11
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])],
+ [AM_DEFAULT_VERBOSITY=1
+ AC_SUBST(AM_DEFAULT_VERBOSITY)])
+
AC_DEFINE_UNQUOTED(PYGST_MAJOR_VERSION, $PACKAGE_VERSION_MAJOR, [PyGst major version])
AC_DEFINE_UNQUOTED(PYGST_MINOR_VERSION, $PACKAGE_VERSION_MINOR, [PyGst minor version])
AC_DEFINE_UNQUOTED(PYGST_MICRO_VERSION, $PACKAGE_VERSION_MICRO, [PyGst micro version])
@@ -353,15 +358,11 @@ AM_CHECK_PYTHON_LIBS(,[AC_MSG_ERROR(could not find Python lib)])
AG_GST_SET_PLUGINDIR
-SHAVE_INIT([common],[enable])
-
AC_OUTPUT([
Makefile
codegen/Makefile
common/Makefile
common/m4/Makefile
- common/shave
- common/shave-libtool
gst/Makefile
gst/gstversion.override
gst/extend/Makefile