summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2005-07-01 10:47:25 +0000
committerEdward Hervey <bilboed@bilboed.com>2005-07-01 10:47:25 +0000
commitf3ec338b76d5568b4c66afc66b60950097a3549d (patch)
treead08853d62266d6a1d330e9154ee71aa6d8fec51 /Makefile.am
parentb35b212bf8d848ba8c97c727b1d47ece0c79b025 (diff)
Modifications to have parallel-installable gst-python
Original commit message from CVS: * Makefile.am: * configure.ac: * gst/Makefile.am: * pygst.py.in: Modifications to have parallel-installable gst-python Works more or less in the same way as pygtk: import pygst pygst.require('0.9') import gst
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1512450..c0b85ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,3 +18,16 @@ EXTRA_DIST = \
RELEASE
include $(top_srcdir)/common/release.mak
+
+# install pth file.
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pythondir)
+ echo "gst-$(GST_MAJORMINOR)" > $(DESTDIR)$(pyexecdir)/pygst.pth
+install-exec-local:
+ $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
+ echo "gst-$(GST_MAJORMINOR)" > $(DESTDIR)$(pyexecdir)/pygst.pth
+uninstall-local:
+ rm -f $(DESTDIR)$(pythondir)/pygst.pth $(DESTDIR)$(pyexecdir)/pygst.pth
+
+# this file is common to all pygtk versions.
+pyexec_PYTHON = pygst.py