summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid I. Lehn <dlehn@users.sourceforge.net>2004-01-27 05:51:53 +0000
committerDavid I. Lehn <dlehn@users.sourceforge.net>2004-01-27 05:51:53 +0000
commit11e199b27c962389e45b07a733ec1a3bb1ecd322 (patch)
treeb76440eb1b10680b278f8bd24d0bae0ee54f5dd9 /Makefile.am
parentcf8c160f13157991ef3bca3cad6f2285477d5906 (diff)
Makefile.am: add gstinterfaces dir
Original commit message from CVS: * Makefile.am: add gstinterfaces dir * configure.ac: get interfaces include dirs * gstreamer/.cvsignore: add .py[co] * gstreamer/0.6.defs: * gstreamer/0.6.override: * gstreamer/0.7.defs: * gstreamer/0.7.override: * gstreamer/common.defs: * gstreamer/common.override: rearrange code for both 0.6 and 0.7 support * gstreamer/Makefile.am: add -fno-strict-aliasing due to python issues * gstinterfaces/.cvsignore: * gstinterfaces/0.7.c: * gstinterfaces/0.7.defs: * gstinterfaces/0.7.h: * gstinterfaces/0.7.override: * gstinterfaces/Makefile.am: * gstinterfaces/__init__.py: * gstinterfaces/arg-types.py: * gstinterfaces/common.c: * gstinterfaces/common.defs: * gstinterfaces/common.h: * gstinterfaces/common.override: * gstinterfaces/gstinterfacesmodule.c: messy start of interfaces handling
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c0c9a38..5126195 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,9 +4,15 @@ else
SUBDIRS_DOCS =
endif
-SUBDIRS = gstreamer pkgconfig examples $(SUBDIRS_DOCS) testsuite
+if GST_0_6
+INTERFACESDIR =
+else
+INTERFACESDIR = gstinterfaces
+endif
-DIST_SUBDIRS = gstreamer pkgconfig examples docs testsuite
+UNCONDDIRS = gstreamer pkgconfig examples testsuite
+SUBDIRS = $(UNCONDDIRS) $(SUBDIRS_DOCS) $(INTERFACESDIR)
+DIST_SUBDIRS = $(UNCONDDIRS) docs gstinterfaces
EXTRA_DIST = \
gst-python.spec.in gst-python.spec README-docs