summaryrefslogtreecommitdiff
path: root/ext/soup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/soup/Makefile.am')
-rw-r--r--ext/soup/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/ext/soup/Makefile.am b/ext/soup/Makefile.am
index 63e5fec9e..8b5de4a23 100644
--- a/ext/soup/Makefile.am
+++ b/ext/soup/Makefile.am
@@ -1,13 +1,13 @@
-plugin_LTLIBRARIES = libgstsouphttpsrc.la
+plugin_LTLIBRARIES = libgstsoup.la
-libgstsouphttpsrc_la_SOURCES = gstsouphttpsrc.c gstsouphttpclientsink.c gstsouputils.c gstsoup.c
+libgstsoup_la_SOURCES = gstsouphttpsrc.c gstsouphttpclientsink.c gstsouputils.c gstsoup.c
-libgstsouphttpsrc_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
+libgstsoup_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_CFLAGS) $(SOUP_CFLAGS) \
-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_48 \
-DSOUP_VERSION_MAX_ALLOWED=SOUP_DEPRECATED_IN_2_48
-libgstsouphttpsrc_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgsttag-@GST_API_VERSION@ $(GST_BASE_LIBS) $(SOUP_LIBS)
-libgstsouphttpsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-libgstsouphttpsrc_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+libgstsoup_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgsttag-@GST_API_VERSION@ $(GST_BASE_LIBS) $(SOUP_LIBS)
+libgstsoup_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstsoup_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
noinst_HEADERS = gstsouphttpsrc.h gstsouphttpclientsink.h gstsouputils.h