summaryrefslogtreecommitdiff
path: root/ext/mpg123/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/mpg123/meson.build')
-rw-r--r--ext/mpg123/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/ext/mpg123/meson.build b/ext/mpg123/meson.build
index a575449bd..3891fd7d0 100644
--- a/ext/mpg123/meson.build
+++ b/ext/mpg123/meson.build
@@ -1,13 +1,9 @@
-mpg123_sources = [
- 'gstmpg123audiodec.c',
-]
-
mpg123_dep = dependency('libmpg123', version : '>= 1.3', required : false)
if mpg123_dep.found()
gstmpg123 = library('gstmpg123',
- mpg123_sources,
- c_args : ugly_args,
+ 'gstmpg123audiodec.c',
+ c_args : gst_plugins_good_args,
include_directories : [configinc],
dependencies : [gstaudio_dep, mpg123_dep],
install : true,