summaryrefslogtreecommitdiff
path: root/gst-libs/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/ext/Makefile.am')
-rw-r--r--gst-libs/ext/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/gst-libs/ext/Makefile.am b/gst-libs/ext/Makefile.am
index b91d01c..883c664 100644
--- a/gst-libs/ext/Makefile.am
+++ b/gst-libs/ext/Makefile.am
@@ -1,3 +1,13 @@
+# we have to put in a little hack here for integration to work well
+# ffmpeg can't be in SUBDIRS, because then automake will try to descend in it
+# and find conditionals it doesn't know.
+
+# so,
+# - don't put it in SUBDIRS so automake doesn't descend
+# - put it in DIST_SUBDIRS so make dist picks up the subtree
+# - add an all-local hook so it does get built
+# this also satisfies make distcheck
+
SUBDIRS =
DIST_SUBDIRS = ffmpeg