summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 10 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index a5d6d40..9ce3684 100644
--- a/meson.build
+++ b/meson.build
@@ -130,7 +130,14 @@ foreach extra_arg : warning_flags
endif
endforeach
-subdir('validate')
+i18n = import('i18n')
+python3 = import('python3')
+if get_option('disable_validate') == false
+ subdir('validate')
+endif
+
+if get_option('disable_debug_viewer') == false
+ subdir('debug-viewer')
+endif
-python3 = import('python3').find_python()
-run_command(python3, '-c', 'import shutil; shutil.copy("hooks/multi-pre-commit.hook", ".git/hooks/pre-commit")')
+run_command(python3.find_python(), '-c', 'import shutil; shutil.copy("hooks/multi-pre-commit.hook", ".git/hooks/pre-commit")') \ No newline at end of file