summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2012-09-07 23:43:57 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2012-09-07 23:45:12 +0530
commit3e3c9ef67be16d0cb8a615b85449654865d19bf3 (patch)
tree1c1536db7467c9ab1eb848c02fe6809e818f26e0 /configure.ac
parent6b52b4785615c3d95c54fa2dfdb1d7d6fb1cef35 (diff)
Revert "build: Merge bluez pkg-config checks into one"
Keeping the SBC check separate means we can keep the SBC_LIBS/CFLAGS separate, which is cleaner. Thanks to Jan Steffens for pointing out that this was broken (SBC_* wasn't actually changed to match the configure change). This reverts commit da5078e5c7762557c357da4825f8927bf3162532.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ca95d188a..06923e3b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -963,7 +963,10 @@ AC_ARG_ENABLE([bluez],
AS_HELP_STRING([--disable-bluez],[Disable optional BlueZ support]))
AS_IF([test "x$enable_bluez" != "xno"],
- [PKG_CHECK_MODULES(BLUEZ, [ bluez >= 3.0 sbc >= 1.0 ], HAVE_BLUEZ=1, HAVE_BLUEZ=0)],
+ [PKG_CHECK_MODULES(BLUEZ, [ bluez >= 3.0 ], HAVE_BLUEZ=1, HAVE_BLUEZ=0)],
+ HAVE_BLUEZ=0)
+AS_IF([test "x$enable_bluez" != "xno"],
+ [PKG_CHECK_MODULES(SBC, [ sbc >= 1.0 ], HAVE_BLUEZ=1, HAVE_BLUEZ=0)],
HAVE_BLUEZ=0)
AS_IF([test "x$HAVE_DBUS" != "x1"], HAVE_BLUEZ=0)