summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2011-07-07 19:47:51 +1000
committerErik de Castro Lopo <erikd@mega-nerd.com>2011-07-07 19:47:51 +1000
commit24fac32d57339c81ba8d3a6be26dd74d4f803bca (patch)
treed2eef8c49994d096c06baab21ff8ec632d4ab26a /tests/Makefile.am
parentccff89c0916982725aba0bd862e404cdb63a457b (diff)
Add 'checkprograms' Make target.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am46
1 files changed, 24 insertions, 22 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ce23202..1d2052b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,6 +34,30 @@ EXTRA_DIST = $(autogen_sources)
CLEANFILES = *~
#===============================================================================
+# If we're cross compiling from Linux to Windows and running the test suite
+# under Wine, we need a symbolic link to the generated libsndfile DLL.
+
+if LINUX_MINGW_CROSS_TEST
+
+$(check_PROGRAMS) : libsndfile-1.dll
+
+libsndfile-1.dll :
+ ln -s $(top_builddir)/src/.libs/$@ $@
+
+clean-local :
+ -rm -f libsndfile-1.dll
+
+endif
+
+#===============================================================================
+
+check: test_wrapper.sh
+ sh test_wrapper.sh
+
+# Need this target to force building of test programs.
+checkprograms : $(check_PROGRAMS)
+
+#===============================================================================
sfversion_SOURCES = sfversion.c
sfversion_LDADD = $(top_builddir)/src/libsndfile.la
@@ -185,25 +209,3 @@ genfiles : write_read_test.c pcm_test.c header_test.c utils.c \
scale_clip_test.c pipe_test.c floating_point_test.c rdwr_test.c \
benchmark.c
-#===============================================================================
-# If we're cross compiling from Linux to Windows and running the test suite
-# under Wine, we need a symbolic link to the generated libsndfile DLL.
-
-if LINUX_MINGW_CROSS_TEST
-
-$(check_PROGRAMS) : libsndfile-1.dll
-
-libsndfile-1.dll :
- ln -s $(top_builddir)/src/.libs/$@ $@
-
-clean-local :
- -rm -f libsndfile-1.dll
-
-endif
-
-#===============================================================================
-
-check: test_wrapper.sh
- sh test_wrapper.sh
-
-