summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2005-11-30 11:38:24 +0000
committerTakashi Iwai <tiwai@suse.de>2005-11-30 11:38:24 +0000
commitdb1e39a4e847cce30b27a8585364963f8cbbb0c9 (patch)
tree6a3da5037c8bc770d641257b778d17c99e744802 /src/Makefile.am
parent79c3d0a1efd42414547430dc6801373a3a927e6f (diff)
Allow partial build with selected components
Add --enable-* and --with-pcm-plugins configure options for partial builds. User can choose the core components (pcm, mixer, rawmidi, hwdep, seq, instr) via --enable-xxx or --disable-xxx option. As default, all components are enabled. The PCM plugins to build can be selected via --with-pcm-plugins option. For example, to build only rate and linear plugin, pass --with-pcm-plugins=rate,linear Passing "all" will select all plugins (it's the default value). The plug plugin will select linear and copy plugins automatically. The other auto conversions of plug plugin are enabled only when the corresponding plugin is selected.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 29 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5f5d76c8..f7cc81df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,3 @@
-SUBDIRS=control mixer pcm rawmidi timer hwdep seq instr compat conf alisp
EXTRA_DIST=Versions
COMPATNUM=@LIBTOOL_VERSION_INFO@
@@ -10,12 +9,35 @@ endif
lib_LTLIBRARIES = libasound.la
libasound_la_SOURCES = conf.c confmisc.c input.c output.c async.c error.c dlmisc.c socket.c shmarea.c userfile.c names.c
-libasound_la_LIBADD = control/libcontrol.la \
- mixer/libmixer.la \
- pcm/libpcm.la \
- rawmidi/librawmidi.la timer/libtimer.la \
- hwdep/libhwdep.la seq/libseq.la instr/libinstr.la \
- compat/libcompat.la alisp/libalisp.la -lm -ldl -lpthread
+
+SUBDIRS=control
+libasound_la_LIBADD = control/libcontrol.la
+if BUILD_MIXER
+SUBDIRS += mixer
+libasound_la_LIBADD += mixer/libmixer.la
+endif
+if BUILD_PCM
+SUBDIRS += pcm timer
+libasound_la_LIBADD += pcm/libpcm.la timer/libtimer.la
+endif
+if BUILD_RAWMIDI
+SUBDIRS += rawmidi
+libasound_la_LIBADD += rawmidi/librawmidi.la
+endif
+if BUILD_HWDEP
+SUBDIRS += hwdep
+libasound_la_LIBADD += hwdep/libhwdep.la
+endif
+if BUILD_SEQ
+SUBDIRS += seq
+libasound_la_LIBADD += seq/libseq.la
+endif
+if BUILD_INSTR
+SUBDIRS += instr
+libasound_la_LIBADD += instr/libinstr.la
+endif
+SUBDIRS += compat conf alisp
+libasound_la_LIBADD += compat/libcompat.la alisp/libalisp.la -lm -ldl -lpthread
libasound_la_LDFLAGS = -version-info $(COMPATNUM)
AM_LDFLAGS = $(VSYMS)