summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2013-06-18 18:03:05 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2013-07-23 23:59:34 +0100
commit2663203cd6994166e107e796c4724a4ed3b59370 (patch)
tree658300367b3eb1856f8058be276e71d88f01a682 /configure.ac
parent9fe360bf2be5c959fb21835955ef550098ccbbf0 (diff)
configure.ac: Check for python at configure time when building XWin with AIGLX
Check for python at configure time when building XWin with AIGLX, it's used to generate the wrapper code for native GL functions. Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Colin Harrison <colin.harrison@virgin.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0d0fd700..c6ecba418 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1944,6 +1944,10 @@ if test "x$XWIN" = xyes; then
dnl XWin with AIGLX requires OpenGL spec files in order to generate wrapper code for native GL functions
if [test "x$XWIN" = xyes && test "x$AIGLX" = xyes] ; then
+ AC_CHECK_PROG(PYTHON, python, python)
+ if test -z "$PYTHON"; then
+ AC_MSG_ERROR([python not found])
+ fi
if test "x$KHRONOS_SPEC_DIR" = "xauto" ; then
PKG_CHECK_MODULES([KHRONOS_OPENGL_REGISTRY], [khronos-opengl-registry])
KHRONOS_SPEC_DIR=`pkg-config khronos-opengl-registry --variable=specdir`