Age | Commit message (Collapse) | Author | Files | Lines |
|
|
|
This tree doesn't have the bug, but I'd like to bring the change that
was buggy over.
|
|
This fixes warnings when building the testsuite, due to char * vs void
* in prototypes.
|
|
Here, we change 'create' to accept the hash function.
This simplifies the interface for 'insert', 'search', 'contains', and
'remove' which no longer need to pass a hash value, making them more
convenient to use.
To avoid any reduction in performance, the previous interfaces for
'insert' and 'search' are still available as 'insert_pre_hashed' and
'search_pre_hashed'. This avoids redundant hashing in cases where the
caller already has a hash value. (The common case is to has once
before 'search_pre_hashed' and then reuse that value for
'insert_pre_hashed'.)
The implementation takes advantage of the 'insert_pre_hashed' version
when performing hash_rehash as part of resizing the table.
Note that 'remove' does not need a pre_hashed variant since 'remove'
is already a convenience function on top of 'remove_entry', and
'remove_entry' already has access to the hash value inside of the
entry.
Similarly, 'contains' does not need a pre_hashed variant since it is a
convnience function on top of 'search' which already has a
'search_pre_hashed' variant.
In this commit, the tests are modified such that roughly half of the
previous callers of 'search' and 'insert' are changed to the new
interface and the other half remain with the old interface (now named
'search_pre_hashed' and 'insert_pre_hashed').
v2: Make the new method call style consistent with the key equality
method (change by anholt).
|
|
|
|
These are convenience functions on top of set_search and
int_set_search. With a set, containment is often the most important
notion of interest, and it helps to be able to query this without
needing to declare a local struct set_entry*.
v2: Whitespace consistency (changes by anholt)
|
|
The new 'remove' function provides a parallel interface to that of
search, (removing an entry matching the provided data). The former
remove function (which accepts a pointer to a known entry) is renamed
to 'remove_entry'.
This new 'remove' is a simple convenience function which calls
'search' and then 'remove_entry'. As can be seen in the updates to the
test suite, there are cases where the caller was already doing exactly
that, so the new interface simplifies such uses.
v2: Whitespace consistency change (by anholt)
|
|
This extends the language from the source files into the Makefiles as well.
The most significant change is from "ADAM JACKSON" to "THE AUTHORS OR
COPYRIGHT HOLDERS". While I'm sure that Adam would appreciate any
reduction in liability, the intent of this language is to disclaim
liability for the actual authors and copyright holders.
(I don't know that Adam actually has any copyright interest in this
implementation, but if he does, he's still covered by the wider
language.)
|
|
Just enough to keep "git status" clean after running "make check".
|
|
While it was easy to produce, it's easier to do it once and maintain it than
leave this up to every possible user. Plus, it means it gets testing.
|