summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 14 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 787afb7..7aa1b3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.59)
-AC_INIT(gypsy, 0.5, http://www.openedhand.com/~iain/gypsy)
+AC_INIT(gypsy, 0.6, http://www.openedhand.com/~iain/gypsy)
AC_CONFIG_SRCDIR(src/main.c)
AM_CONFIG_HEADER(config.h)
@@ -15,40 +15,16 @@ AC_PROG_MAKE_SET
AC_PROG_GCC_TRADITIONAL
AM_PROG_LIBTOOL
-AC_ARG_WITH(distro, AC_HELP_STRING([--with-distro=DISTRO], [Specify the Linux distribution to target: One of redhat, suse, gentoo, debian, arch, slackware or paldo]))
-if test "z$with_distro" = "z"; then
- AC_CHECK_FILE(/etc/debian_version,with_distro="debian")
- if test "z$with_distro" = "z"; then
- with_distro=`lsb_release -is`
- fi
-fi
-with_distro=`echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]' `
-if test "z$with_distro" = "z"; then
- echo "Linux distribution autodetection failed, you must specify the distribution to target using --with-distro=DISTRO"
- exit 1
-else
- case $with_distro in
- debian) ;;
- *)
- echo "Your distribution (${with_distro}) is not yet supported! (patches welcome)"
- exit 1
- ;;
- esac
+GYPSY_PC_MODULES='glib-2.0 dbus-glib-1 >= 0.60'
+
+AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--disable-bluetooth],[Enable support for Bluetooth GPS devices]),, enable_bluetooth=yes)
+
+if test x$enable_bluetooth = xyes; then
+ AC_DEFINE(HAVE_BLUEZ,1,[Define if we have Bluez])
+ GYPSY_PC_MODULES="$GYPSY_PC_MODULES bluez"
fi
-AM_CONDITIONAL(TARGET_REDHAT, test x"$with_distro" = xredhat)
-AM_CONDITIONAL(TARGET_SUSE, test x"$with_distro" = xsuse)
-AM_CONDITIONAL(TARGET_GENTOO, test x"$with_distro" = xgentoo)
-AM_CONDITIONAL(TARGET_DEBIAN, test x"$with_distro" = xdebian)
-AM_CONDITIONAL(TARGET_SLACKWARE, test x"$with_distro" = xslackware)
-AM_CONDITIONAL(TARGET_ARCH, test x"$with_distro" = xarch)
-AM_CONDITIONAL(TARGET_PALDO, test x"$with_distro" = xpaldo)
-AM_CONDITIONAL(TARGET_FRUGALWARE, test x"$with_distro" = xfrugalware)
-PKG_CHECK_MODULES(GYPSY, [
- glib-2.0
- bluez
- dbus-glib-1 >= 0.60
-])
+PKG_CHECK_MODULES(GYPSY, $GYPSY_PC_MODULES)
AC_SUBST(GYPSY_LIBS)
AC_SUBST(GYPSY_CFLAGS)
@@ -67,6 +43,9 @@ AC_DEFINE_UNQUOTED(DBUS_SERVICES_DIR, "$DBUS_SERVICES_DIR", [Where services dir
CFLAGS="$CFLAGS -g -Wall -Werror -Wno-format"
+# TODO: add --with-xsltproc argument to override PATH
+AC_CHECK_PROGS(XSLT, xsltproc)
+
AC_CONFIG_FILES([
Makefile
interfaces/Makefile
@@ -75,9 +54,9 @@ gypsy/Makefile
examples/Makefile
docs/Makefile
docs/reference/Makefile
+docs/reference/version.xml
+docs/tools/Makefile
gypsy.pc
-initscript/Makefile
-initscript/Debian/Makefile
])
AC_OUTPUT