summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorZbigniew Kempczyński <zbigniew.kempczynski@intel.com>2024-03-06 16:02:19 +0100
committerZbigniew Kempczyński <zbigniew.kempczynski@intel.com>2024-03-11 11:11:18 +0100
commitc7c6bd4e89935e295badec57313b04eb11665eaf (patch)
tree3c0ff8710a006c2e04cf1a0b916c535879efffb7 /tests/meson.build
parent26504be9e67b99a772699bade2b12bc8086121ed (diff)
tests/xe_render_copy: Add render-copy test for xe
Fill the gap with testing render-copy for xe driver. Currently only few basic render-copy checks are executing within xe_intel_bb@render. xe_render_copy introduces new checks comparing to gem_render_copy test. During my work on enabling render-copy on LunarLake I've used same r6 subregisters like on previous platforms what causes full render-copy between surfaces worked but partials were not. I decided to include square and v/h stripes tests to verify cofficients for barycentric coordinates matches expected <x,y> position. More stressful is random subtest which randomizes width and height as well as division point (it copies four rectangles to destination surface). Cc: Matthew Auld <matthew.auld@intel.com> Reviewed-by: Matthew Auld <matthew.auld@intel.com> Link: https://lore.kernel.org/r/20240306150219.301977-5-zbigniew.kempczynski@intel.com Signed-off-by: Zbigniew Kempczyński <zbigniew.kempczynski@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 02cbc3780..a856510fc 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -309,6 +309,7 @@ intel_xe_progs = [
'xe_pm_residency',
'xe_prime_self_import',
'xe_query',
+ 'xe_render_copy',
'xe_vm',
'xe_waitfence',
'xe_spin_batch',