summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorTejas Upadhyay <tejas.upadhyay@intel.com>2023-09-15 18:14:09 +0530
committerJanga Rahul Kumar <janga.rahul.kumar@intel.com>2023-09-22 17:43:20 +0530
commit05d14fd260a3cf9dc00ed24733d5589eee32ec08 (patch)
treeee387b518dcc19082bf363e322b35215f7022afb /tests/meson.build
parent70d59545b989e3f4d3e66a97ce5e608729609a18 (diff)
tests/xe_drm_fdinfo: Add tests to read and verify fdinfo
Add tests to verify fdinfo published by xe KMD with following subtests : @basic @drm-total-residents @drm-shared @drm-active Example fdinfo format: pos: 0 flags: 0100002 mnt_id: 23 ino: 1140 drm-driver: xe drm-client-id: 19 drm-pdev: 0000:4d:00.0 drm-total-system: 0 drm-shared-system: 0 drm-active-system: 0 drm-resident-system: 0 drm-purgeable-system: 0 drm-total-gtt: 4 KiB drm-shared-gtt: 0 drm-active-gtt: 0 drm-resident-gtt: 4 KiB drm-total-vram0: 20 KiB drm-shared-vram0: 0 drm-active-vram0: 0 drm-resident-vram0: 20 KiB drm-total-vram1: 20 KiB drm-shared-vram1: 0 drm-active-vram1: 0 drm-resident-vram1: 20 KiB TODO: drm-purgeable test is not possbile as we consider objects in system memory to be purgeable but current xe KMD does not allow BOs to be created in system memory (instead KMD creates it in XE_PL_TT which is VRAM backed system memory). V4: - Put pre_size checks - Rahul - Check all test for all regions - Rahul V3: - Expand basic test - Rahul - Use defined var at all places - Rahul - Update commit message - Rahul - Adapt spin_init API change V2: - Replace printf with igt_info - Kamil - run checkpatch - Kamil - use igt_assert_f - Kamil Reviewed-by: Janga Rahul Kumar<janga.rahul.kumar@intel.com> Signed-off-by: Tejas Upadhyay <tejas.upadhyay@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 31492bf7b..974cb433b 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -276,6 +276,7 @@ intel_xe_progs = [
'xe_compute',
'xe_dma_buf_sync',
'xe_debugfs',
+ 'xe_drm_fdinfo',
'xe_evict',
'xe_exec_balancer',
'xe_exec_basic',