summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2019-07-01 15:21:53 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2019-07-08 09:29:43 +0300
commitd2a10fb734c34b72eb17c58d9dae813321112ee6 (patch)
treedc8ad87687304d51b7c6d248b8a55e8e2e747a83 /meson.build
parent2f273018ac42f20de39f05f7d7e480d53b78c9f1 (diff)
docs: Embed subtest descriptions in the documentation
This rewrites generate_description_xml in Python, so that we generate properly escaped XML. The switch also makes the code more manageable. Changes in the generated docbook: 1. subtests are not simply listed anymore, they are now another (sub)section 2. subtests are now linkable, e.g. docs/igt-kms-tests.html#kms_hdmi_inject@inject-4k 3. subtest's section now includes output of --describe Python is required already by gtk-doc and we are not using anything other than the standard library. v2: keep the part of the subtest name after the last match (Simon) explicitly require python3 (Petri) v3: make sure that the tail of the subtest name after the last keyword match is included (Simon) Cc: Daniel Vetter <daniel@ffwll.ch> Cc: Petri Latvala <petri.latvala@intel.com> Cc: Simon Ser <simon.ser@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Acked-by: Petri Latvala <petri.latvala@intel.com> Reviewed-by: Simon Ser <simon.ser@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f0cb2543c..0629d441d 100644
--- a/meson.build
+++ b/meson.build
@@ -303,7 +303,8 @@ subdir('overlay')
subdir('man')
gtk_doc = dependency('gtk-doc', required : build_docs)
-if build_tests and gtk_doc.found()
+python3 = find_program('python3', required : build_docs)
+if build_tests and gtk_doc.found() and python3.found()
subdir('docs')
elif build_docs.enabled()
error('Documentation requires building tests')