summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMauro Carvalho Chehab <mchehab@kernel.org>2023-03-22 07:17:09 +0100
committerMauro Carvalho Chehab <mchehab@kernel.org>2023-03-24 15:36:40 +0100
commit88c3ee6d65020de07dc9800a82a23c90539e22c9 (patch)
tree7af80eda24455dc3e6a4d287ba0b68b5964f272b /meson.build
parent482c12c333a76ede0906b3968cd3b1fb0e9bf570 (diff)
meson: get rid of a future-deprecated warning
A warning is generated with newer meson versions: NOTICE: Future-deprecated features used: * 0.56.0: {'meson.source_root'} While there is a new macro to get it, that would rise the dependency chain to meson 0.56. So, instead, just store it on a variable. Reviewed-by: Kamil Konieczny <kamil.konieczny@linux.intel.com> Signed-off-by: Mauro Carvalho Chehab <mchehab@kernel.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b896283e3..12d5113a9 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,9 @@ if get_option('b_ndebug') != 'false'
error('Building without -Db_ndebug=false is not supported')
endif
+# meson.source_root is marked as a future-deprecated feature
+source_root = meson.current_source_dir()
+
cc = meson.get_compiler('c')
# Also make sure that the user doesn't have -DNDEBUG defined in their config