summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMaíra Canal <mcanal@igalia.com>2022-11-29 15:40:33 -0300
committerKamil Konieczny <kamil.konieczny@linux.intel.com>2022-12-01 12:57:18 +0100
commit1bc9b83817f4e7950bfa571406496ecf57886346 (patch)
tree5fd8ca4e4c03d6e96101e7e69d21c8084148a385 /meson.build
parent2c92991264061913ff2b2603be0bd7ba085f6214 (diff)
tests/v3d: Move V3D tests to their own folder
With the introduction of new tests to V3D, in order to avoid polluting the main tests folder, move the V3D tests to a separate folder. Moreover, create a subdir "v3d" to install the V3D-specific tests. Reviewed-by: Melissa Wen <mwen@igalia.com> Signed-off-by: Maíra Canal <mcanal@igalia.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3e937f5a5..709c7a6c7 100644
--- a/meson.build
+++ b/meson.build
@@ -260,6 +260,7 @@ includedir = get_option('includedir')
libdir = get_option('libdir')
libexecdir = join_paths(get_option('libexecdir'), 'igt-gpu-tools')
amdgpudir = join_paths(libexecdir, 'amdgpu')
+v3ddir = join_paths(libexecdir, 'v3d')
mandir = get_option('mandir')
pkgconfigdir = join_paths(libdir, 'pkgconfig')
python3 = find_program('python3', required : true)
@@ -295,10 +296,17 @@ if get_option('use_rpath')
amdgpudir_rpathdir = join_paths(amdgpudir_rpathdir, '..')
endforeach
amdgpudir_rpathdir = join_paths(amdgpudir_rpathdir, libdir)
+
+ v3d_rpathdir = '$ORIGIN'
+ foreach p : v3ddir.split('/')
+ v3d_rpathdir = join_paths(v3d_rpathdir, '..')
+ endforeach
+ v3d_rpathdir = join_paths(v3d_rpathdir, libdir)
else
bindir_rpathdir = ''
libexecdir_rpathdir = ''
amdgpudir_rpathdir = ''
+ v3d_rpathdir = ''
endif
subdir('lib')