summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2010-01-18 22:12:23 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2010-01-22 23:01:50 +0000
commitd2f251f84b326c5f8825c9a631ea729f21891580 (patch)
tree128c23acc85c20f66c12e193c8e46f14aa5e1863 /configure.ac
parent934d0d0d6585eb7638c7db597c40dd821092c034 (diff)
configure: Globally define AC_GNU_SOURCE
We were using _GNU_SOURCE throughout the codebase, so simply define it once during configure. This is the easiest method to enable recursive mutexes using pthreads, as required in a pending patch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27404cd3..d704353f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ CAIRO_PARSE_VERSION
AC_INIT([cairo],
[cairo_version_major.cairo_version_minor.cairo_version_micro],
[http://bugs.freedesktop.org/enter_bug.cgi?product=cairo])
+AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR(src/cairo.h)
AC_CONFIG_HEADERS(config.h)
AC_CONFIG_AUX_DIR(build)
@@ -13,6 +14,8 @@ AC_PROG_LIBTOOL dnl ([1.4]) Don't remove!
DOLT dnl Make my libtool fast!
GTK_DOC_CHECK([1.6])
+AC_GNU_SOURCE
+
dnl ===========================================================================
dnl
dnl The order of the includes here is rather important